Amplified Parts Lollar Pickups

Amplified Parts Lollar Pickups Guitar Pickups

Amplified Parts Lollar Pickups Guitar Pickups

Join Strat-Talk Today

Ground hum dilemma

Discussion in 'Pickup Forum' started by Lonn, Dec 23, 2017.

  1. Lonn

    Lonn Mod Admin Staff Member Strat-Talk Supporter

    Admin Post
    Where in Indiana are you? I’m in Carmel.
     

  2. Williamwolka

    Williamwolka Strat-Talker

    Age:
    36
    148
    Dec 10, 2017
    Indiana
    Fort Wayne, I love Carmel, cool place.
     

  3. stratman323

    stratman323 Dr. Stratster Strat-Talk Supporter

    Age:
    57
    Apr 21, 2010
    London, UK
    It's very brave to say that to one of the mods.....
     
    CigBurn and fezz parka like this.

  4. Teleplayer

    Teleplayer Strat-Talker

    499
    May 29, 2012
    Sydney, Australia
    Check to see if you wired the Jack correctly and didn't mix up the connections.
     

  5. Lonn

    Lonn Mod Admin Staff Member Strat-Talk Supporter

    Admin Post
    If the jack is wired backwards it makes a totally different sound.

    "You're a big bag of water..
    It's very brave to say that to one of the mods...."

    I've been called much worse. :D
     

  6. fezz parka

    fezz parka R.P.M. (Retired Professional Musician) Strat-Talk Supporter

    Age:
    59
    Apr 21, 2011
    Like Nowheresville, man.
    We're all around 65% water. :)
     
    Hairy Bear and Bodean like this.

  7. Lonn

    Lonn Mod Admin Staff Member Strat-Talk Supporter

    Admin Post
    Give or take a few % of piss and vinegar. :whistling::p
     

  8. Thrup'ny Bit

    Thrup'ny Bit Captain Crapocaster Strat-Talk Supporter

    Age:
    59
    May 21, 2010
    In t'grim North
    And a gallon or so of Guinness...
     
    Hairy Bear and fezz parka like this.

  9. Hawk8789

    Hawk8789 Strat-Talker

    209
    Apr 11, 2013
    Las Vegas, Nv
    Probably no help, but I installed new pickups in my 335 and had a ton of hum if I was not touching the bridge, the pickup, or the pot. I put the strings on anyway, and the hum went away. I have no idea why, but it apparently needed the strings on.