Amplified Parts Lollar Pickups

Amplified Parts Lollar Pickups

Amplified Parts Lollar Pickups Guitar Pickups

Late 60's Webster TP14 Tube Amp - Info/Help Needed Please

Discussion in 'Amp Input - Normal or Bright' started by medicchief, Aug 9, 2018.

  1. medicchief

    medicchief Strat-Talker Strat-Talk Supporter

    437
    Feb 10, 2018
    Arkansas
    Greetings friends! I picked up this old Webster PA amp at a flea market today, for $15. I checked the web for information and found that several players are using them (nice vintage tone/sweet mids, etc). I also noticed they were bringing a few hundred bucks in working condition. That said, I brought it home and cleaned it up. I plugged it in and it powers up (light comes on), the 2 6V6's and 6AU6 light up, but the 12AX7 and the EF86 don't. FYI, the Treble knob is also the on/off switch. It's 14 watts of Class A power and I've got a spare Jensen C12N speaker I can make a cabinet for. I'd like to get it working for the fun of it. I am looking for a schematic and any info on the amp, if anyone can help. Here's some pictures. Thanks in advance!
    IMG_1661.jpg IMG_1658.jpg IMG_1660.jpg IMG_1657.jpg
     
    JustABluesGuy likes this.
  2. Triple Jim

    Triple Jim Senior Stratmaster

    Feb 27, 2018
    North Central NC
    Cool, I'd love to hear it when you get it going.

    A Google images search for "webster tp14 schematic" brings up multiple schematics.
     
    medicchief likes this.
  3. medicchief

    medicchief Strat-Talker Strat-Talk Supporter

    437
    Feb 10, 2018
    Arkansas
    Great, thank you! I've been taking care of kids and just thought I would post, then do some research later.
     
  4. JustABluesGuy

    JustABluesGuy Senior Stratmaster

    Sep 3, 2016
    Houston, TX
    Nice! Looks like a cool project! Post updates!
     
  5. Stevem

    Stevem Strat-O-Master

    986
    Sep 3, 2014
    NY
    The Brown box resistor behind your treble/ on off swt looks cracked and is likely open.

    If this resistor is in the power supply then it likely failed due to one or both of the can type multi section filters mounted on top being bad.

    If this is the cathode resistor for the two 6V6 output tubes then one or both of the tubes are bad.
    One thing a can say for sure is that I can tell your more about what's going on if you post up better Gut shot photos , like 4 of them so I can see things in better detail!

    Do not power this amp up any more until I or someone else gives it a good look over from much better photos!
     
  6. strat_strummer

    strat_strummer Senior Stratmaster Strat-Talk Supporter

    Very cool lookin amp and fun project, good luck....