Noiseless Pickups click/pop when touching pickup screws

mstan2184

New Member!
Nov 15, 2021
6
Minnesota
Hi Everyone,

I installed a set of Gen 4 Noiseless pickups in a 2002 Jimmy Vaughn Tex Mex Strat with new pick guard, tone pots, wiring, pickup switch, and 1/4 input. Essentially all new electronics. They sound great and have worked perfectly, however, recently, if my finger grazes or touches the pickup screws on the high e (string 1) side, there’s a click/pop noise that occurs when I play. Oddly, this doesn’t occur on the low e (string 6) side. The pick guard is fully shielded and I’m using the rubber spacers between the screws and pick guard. Has anyone experienced a similar issue before? Any recommendations for a fix? I removed the pick guard and all the connections are solid, everything looks as it should be. I’m wondering if there’s something wrong with the pickups? Thanks so much for any suggestions! Have a great day!
 

Hal Nico

Senior Stratmaster
Apr 28, 2012
3,712
JAMOADR
Check the mains grounding in your location.

See this post,

 

mstan2184

New Member!
Nov 15, 2021
6
Minnesota
Good thought for sure. I actually had an electrician in last year and they checked the grounds on our mains; I am plugged into grounded outlets. The problem occurs at home and at my studio--both with grounded outlets.
 

Dick Blackmore

Senior Stratmaster
Jan 10, 2017
2,006
Black Hole
with new pick guard
You might want to rub that pickguard down with a dryer sheet. 1 pass usually does it. I'm not sure if the sound you are describing is static but its worth a try. After that I would back those screws out and clean out any shielding tape that is in the threads. I've seen folks push the screw through the holes without cutting the shielding tape first and, in my experience, that can cause issues.

I am a serial pickup swapper not a luthier. YMMV
 


Top